Тарас з Парнаса
нет, просто видел
Anonymous
тут просто есть несколько компаний где треьуются кругдогодично
Anonymous
У меня такая ситуация при пуше в один репазитории мне нужно что бы выполнялся си с другого над реализовать через вот эту штуку
Владимир
нужен
а чего делать надобно?
Danila
Кто-нибудь пытался запускать Percona XTRADb кластер в докере?
Первая нода запустилась нормально, остальные валятся с ошибкой:
2019-07-11T13:32:29.817554Z 0 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.user' doesn't exist
2019-07-11T13:32:29.817598Z 0 [ERROR] Fatal error: Failed to initialize ACL/grant/time zones structures or failed to remove temporary table files.
2019-07-11T13:32:29.817787Z 0 [ERROR] Aborting
Danila
2019-07-11T13:32:29.378720Z 0 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
ᴅⁱᵐⁱᴅʳ0ˡ
Danila
https://www.percona.com/doc/percona-xtradb-cluster/LATEST/install/docker.html
Danila
docker run -d \
-e MYSQL_ROOT_PASSWORD=root \
-e CLUSTER_NAME=cluster1 \
--name=node1 \
--net=pxc-network \
percona/percona-xtradb-cluster:5.7
Danila
docker run -d \
-e MYSQL_ROOT_PASSWORD=root \
-e CLUSTER_NAME=cluster1 \
-e CLUSTER_JOIN=node1 \
--name=node2 \
--net=pxc-network \
percona/percona-xtradb-cluster:5.7
Danila
собственно, всё, что я пытался сделать
ᴅⁱᵐⁱᴅʳ0ˡ
Не хватает учетки для реплики
Danila
У меня такое ощущение, что мускул криво запустился на второй ноде, судя по тому, что он не может открыть всякие системные таблицы
Danila
а про учётку для реплики в офф. доке к образу нет ни слова
Danila
(и даже env var они для этого не выделили)
George
Danila
Т.е. мне надо на каждом сервере создать учётку для реплики?
Andrei
как настроить авто подставление команд docker?
George
Andrei
Danila
Оказалось, перконовцы тихо сменили entrypoint в версии 5.7.26
Danila
И туториал актуален для версии 5.7.25
NM
George
George
Отжайл во всей его красе 😂
Andrei
Установить модуль для bash completion
поставил как в мане https://docs.docker.com/compose/completion/ проверяю так набираю docker in и жму tab жду чтоб он мне подставил или дал список из воспадений но не дает
George
George
А почему docker in? Ааа, inspect
George
Не tmux, screen?
George
В них табы "проглатываются"
Andrei
George
Ubuntu, arch ?
George
У меня на убунту, ОпенСусе и центос все ок
Andrei
да у меня тоже на них ток пересел на mac
George
Мак? Серьезно ? Там действительно может не работать
Nikolay
Nikolay
пашет в zsh
Nikolay
терминал перезапускали после прописывания плагинов в ~/.zshrc?
inqfen
Вообще спустя небольшое время автокомплит становится не нужен
central
когда из контейнера подключаюсь к redis он сбрасывает соединение, наверно потому что слушает только локалхост, а контейнер туда не подпадает, где можно глянуть какой адресс у контейнера, чтобы задать его в конфиге redis?
George
central
как задать имя контейнеру —name че то ноль эффекта дает?
Vasily
central
--name
sudo docker run bot:latest --name StudyRussian
но имя в итоге zen_lalande
Ivgenich
Name до bot, не?
Andrey
Алихан
там флаг после названия образа, а должен быть до него
Andrew
Всем привет, может кто-то подсказать как получить root права на slavenode(удаленной) jenkinsa?)
George
George
aaalitvinov
Ребята привет, дайте чё толковое почитать про докер
aaalitvinov
Для нубов
aaalitvinov
aaalitvinov
И для чего это нужно?
aaalitvinov
Какие плюсы? Использую go
Nikolay
Дмитрий
парни я чет не понял. поднял убунту 18 через докер композ(просто скачал образ). Наставил пакетов, конфиги поправил (напрямую в контейнере). вышел. выполнил docker-compose stop. открыл порт в докер композ файле. выполнил docker-compose up и все чистый контейнер.
aaalitvinov
Вот и я о том же, для чего он мне? Зачем нужна изоляция? Процесс упавший подымать ? Дак тут докер не поможет..
Дмитрий
как это работает (тут много матов )
central
Sergey
Дмитрий
у меня несколько версий приложений, нужно сначала узнать какой заработает 100% и тогда уже из этого собрать контейнер.
Дмитрий
бесполезные состояния он сохраняет а нужные как по закону подлости)
central
Алихан
Там состояние теряется только после docker rm
Алихан
docker stop start должен оставить по идее
Алихан
А
Дмитрий
я использую docker-compose stop и docker-compose up
через докер я не запускаю контейнеры
Алихан
docker-compose мог потереть по идее
Алихан
Если я не ошибаюсь им тоже можно stop/start делать
Алихан
Но там да, наверное стоит докерфайл свой завести