George
не забывайте, что docker - это контейнеризация приложений, а не LXD/LXC - контейнеризация ОСи
Oleg
можно сделать контейнер с systemd, но там особые пляски с бубном
в этом варианте есть разнится на какой ОСи будет он билдится? win\nix
George
хз
Oleg
а что бы не требовал systemd - с помощью /etc/init.d/service start ?
Romuald
Привет! Есть docker-compose django postgres nginx. Как правильно хранить базу, чтобы можно было легко запустить на локалке или перенести на другой сервер?
Fedor
гайз, скажите плиз - существуют ли best practices для настройки VM ESXi под docker ? я не знаю, например параметры sysctl ?
George
это тоже плохая идея )
George
скорее supervisor в ENTRYPOINT 😊
Fedor
я все со вчерашней проблемой "борюсь" , сейчас подозрение на docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default
Oleg
я пока не совсем понимаю задачи
поднять vsts azure agent в докере
George
а готового образа нет?
George
https://hub.docker.com/r/microsoft/vsts-agent/ ?
Ivgenich
Или если не важны сами данные, то просто миграции при старте.
Oleg
а готового образа нет?
да есть, но под определенные требования было легче делать имедж свой, но уперся в то что он запускается через systemd
arts
Гайз, привет. Есть некий сервис, запущенный c --network host. Рядом запущен редис, до которого сервис закономерно достучаться не может. Есть ли способ подключиться к редису без `host`/проброса порта на хост?
George
Он опубликован по порту на хост машине ?
Andrey
Доброго дня суток. Кто нибудь сталкивался с подобными проблемами? Хочу запустить nginx через docker и прокинуть настройки в папку docker run --rm -it -v /var/local/nginx/nginx.conf:/etc/nginx/nginx.conf:ro nginx Получаю сл. ошибку docker: Error response from daemon: OCI runtime create failed: container_linux.go:345: starting container process caused "process_linux.go:430: container init caused \"rootfs_linux.go:58: mounting \\\"/var/local/nginx/nginx.conf\\\" to rootfs \\\"/var/lib/docker/overlay2/ab7daae2fafb5a94a126f3ee703f7b241934ce84386864c4b1f3f0da878dd3f0/merged\\\" at \\\"/var/lib/docker/overlay2/ab7daae2fafb5a94a126f3ee703f7b241934ce84386864c4b1f3f0da878dd3f0/merged/etc/nginx/nginx.conf\\\" caused \\\"not a directory\\\"\"": unknown: Are you trying to mount a directory onto a file (or vice-versa)? Check if the specified host path exists and is the expected type. Создается папка /var/local/nginx/nginx.conf, а не монтируется или линкуется настройка из контейнера. $ docker -v Docker version 18.09.7, build 2d0083d $ cat /etc/issue Ubuntu 19.04 \n \l
Alexander
Пытаюсь запустить контейнер с юпитером на сервере, выдает ошибку: docker: Error response from daemon: failed to start shim: exec: "docker-containerd-shim": executable file not found in $PATH: unknown. Я так понимаю, там какие-то проблемы с $PATH, но как это пофиксить?
Ivgenich
Неа. Не с PATH.
Ivgenich
Сталкивался с этой фигней на днях. Вылечилось тупо рестартом сервиса докера.
Alexander
Сталкивался с этой фигней на днях. Вылечилось тупо рестартом сервиса докера.
Да, спасибо, починилось. Теперь осталось поднять, все, что я уронил .з.
George
Хотя... Редис умеет в файловый сокет ?
Ivgenich
Да, спасибо, починилось. Теперь осталось поднять, все, что я уронил .з.
Есть вероятность, что это чинится проще, просто я устал разбираться и пнул сервис, т.к. косячить он начал на стэйджинге, а не проде. Причем у меня не запуск не работал, у меня не билдился имедж. Ничего внятного гуглением не нашел. Пнул сервис и все ожило.
Ivgenich
А докер свежий, кстати? У меня на старой версии заглючило.
Mikhail
Есть вероятность, что это чинится проще, просто я устал разбираться и пнул сервис, т.к. косячить он начал на стэйджинге, а не проде. Причем у меня не запуск не работал, у меня не билдился имедж. Ничего внятного гуглением не нашел. Пнул сервис и все ожило.
Точно такая же проблема была, весь день докер лагает, что сборка, что запуск. Решилось вроде рестартом тоже, но все равно есть проблемы. Иногда пишет, что заняты какие-то порты контейнерами, хотя контейнеров нет и порты свободны.
Ivgenich
Нет, и не хотелось бы
А если вот так?
Ivgenich
Хотя не.
Ivgenich
В общем пихайте и сервис и редиску в один компоуз и вперед )
Ivgenich
environment: - APP_CELERY_BROKER_URI=redis://redis-app:6379/0 - APP_CELERY_BACKEND_URI=redis://redis-app:6379/1 - APP_CACHE_URI=redis://redis-app:6379/2
arts
В общем пихайте и сервис и редиску в один компоуз и вперед )
Они и так в одном компоузе, только сервис с network_mode: host
Alexander
Сталкивался с этой фигней на днях. Вылечилось тупо рестартом сервиса докера.
Там к бд не был примонтирован вольюм и она улетела в никуда
Alexander
Ура
Alexander
Можно ли как-то достать его фс?
Green
Добрый день. Использую docker-compose. Хотелось бы чтобы изнутри контейнера A был доступен локалхост. И чтобы можно было через другие контенейры обратиться к контейнеру A.
Alexander
что за бд?
Контейнер с Постгрес
Kirill
Kirill
тут ищи
Kirill
один из вольюмов будет твой
Kirill
я по размеру обычно ищу
Kirill
или на пейстбин
Kirill
Контейнер с Постгрес
вольюмы - это просто папки, поэтому так назвал
Green
Green
https://pastebin.com/FxGdTeQY
Green
На локал хост запущен ngnix, который слушает 8888. Нужно чтобы nginx-exporter получил доступ к nginx. А контейнер с prometheus имел доступ к nginx-exporter
Kirill
а тебе обязательно держать все за бриджом?
Kirill
в такой схеме ты не получишь доступ к локалхосту
Green
а тебе обязательно держать все за бриджом?
Ты предлагешь все на хосте запусить?
Kirill
дээ)
Kirill
чтобы у тебя хостова ясеть была доступна для контейнеров
Green
Думал можно без этого, хотя в данном случае не критично
Kirill
без этого - обращаться на внешний адрес
Kirill
локалхост - это твой контейнер здесь будет
Green
Понял, спасибо
Alexander
/var/lib/docker/volumes
Да, спасибо, нашел
Alexander
Вот только как теперь восстановить назад?
Kirill
Вот только как теперь восстановить назад?
никак, просто вынеси в другое место и мапь
Vladimir
Всем привет! Неожиданно на сервере в dockerd поступила команда graceful shutdown. Как определить источник?
Vladimir
Сессий не было в этот момент на сервере открытых
Kirill
Вот только как теперь восстановить назад?
./data/postgresql:/var/lib/postgresql/data вот так мапить, например
Den
куя
Kirill
Сессий не было в этот момент на сервере открытых
тогда - это фантом, если нет данных с логированием, метриками, понимания,что там крутится
Vladimir
Спасибо
Kirill
ну может кто знает, у меня такого никогда не было
Владимир
Всем привет
Владимир
Подскажите что я делаю не так и что тут имеется ввиду
Владимир
# docker run -itd --rm --network=postfix-net -p 25:25 --name=my-postfix postfix:latest 877b4bbb102b33171fdd606cfb6e3526cd5a9d50d0cc646d88248a0466e9eaf2 docker: Error response from daemon: driver failed programming external connectivity on endpoint my-postfix (cb1878df1bdf6d4dd895d49f0e2227d8c9f240db6a5e6b9af0ff012253221919): Error starting userland proxy: listen tcp 0.0.0.0:25: bind: address already in use.
George
написано же