George
не забывайте, что docker - это контейнеризация приложений, а не LXD/LXC - контейнеризация ОСи
George
хз
Oleg
а что бы не требовал systemd - с помощью /etc/init.d/service start ?
Romuald
Привет! Есть docker-compose django postgres nginx.
Как правильно хранить базу, чтобы можно было легко запустить на локалке или перенести на другой сервер?
Fedor
гайз, скажите плиз - существуют ли best practices для настройки VM ESXi под docker ? я не знаю, например параметры sysctl ?
George
это тоже плохая идея )
George
скорее supervisor в ENTRYPOINT 😊
George
Fedor
я все со вчерашней проблемой "борюсь" , сейчас подозрение на docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default
George
George
а готового образа нет?
George
https://hub.docker.com/r/microsoft/vsts-agent/ ?
Ivgenich
Romuald
Ivgenich
Или если не важны сами данные, то просто миграции при старте.
Oleg
а готового образа нет?
да есть, но под определенные требования было легче делать имедж свой, но уперся в то что он запускается через systemd
arts
Гайз, привет.
Есть некий сервис, запущенный c --network host. Рядом запущен редис, до которого сервис закономерно достучаться не может. Есть ли способ подключиться к редису без `host`/проброса порта на хост?
George
George
Он опубликован по порту на хост машине ?
arts
arts
Alexander
Пытаюсь запустить контейнер с юпитером на сервере, выдает ошибку:
docker: Error response from daemon: failed to start shim: exec: "docker-containerd-shim": executable file not found in $PATH: unknown.
Я так понимаю, там какие-то проблемы с $PATH, но как это пофиксить?
Ivgenich
Неа. Не с PATH.
Ivgenich
Сталкивался с этой фигней на днях. Вылечилось тупо рестартом сервиса докера.
Alexander
George
George
Хотя... Редис умеет в файловый сокет ?
Ivgenich
А докер свежий, кстати? У меня на старой версии заглючило.
Mikhail
Есть вероятность, что это чинится проще, просто я устал разбираться и пнул сервис, т.к. косячить он начал на стэйджинге, а не проде. Причем у меня не запуск не работал, у меня не билдился имедж. Ничего внятного гуглением не нашел. Пнул сервис и все ожило.
Точно такая же проблема была, весь день докер лагает, что сборка, что запуск. Решилось вроде рестартом тоже, но все равно есть проблемы.
Иногда пишет, что заняты какие-то порты контейнерами, хотя контейнеров нет и порты свободны.
Ivgenich
Ivgenich
Хотя не.
Ivgenich
В общем пихайте и сервис и редиску в один компоуз и вперед )
Ivgenich
environment:
- APP_CELERY_BROKER_URI=redis://redis-app:6379/0
- APP_CELERY_BACKEND_URI=redis://redis-app:6379/1
- APP_CACHE_URI=redis://redis-app:6379/2
Alexander
Alexander
Ура
Alexander
Можно ли как-то достать его фс?
Green
Добрый день. Использую docker-compose. Хотелось бы чтобы изнутри контейнера A был доступен локалхост. И чтобы можно было через другие контенейры обратиться к контейнеру A.
Kirill
Kirill
Green
Kirill
тут ищи
Kirill
один из вольюмов будет твой
Kirill
я по размеру обычно ищу
Kirill
Kirill
или на пейстбин
Green
Green
https://pastebin.com/FxGdTeQY
Green
На локал хост запущен ngnix, который слушает 8888. Нужно чтобы nginx-exporter получил доступ к nginx. А контейнер с prometheus имел доступ к nginx-exporter
Kirill
а тебе обязательно держать все за бриджом?
Kirill
в такой схеме ты не получишь доступ к локалхосту
Green
Kirill
дээ)
Kirill
чтобы у тебя хостова ясеть была доступна для контейнеров
Green
Думал можно без этого, хотя в данном случае не критично
Kirill
без этого - обращаться на внешний адрес
Kirill
локалхост - это твой контейнер здесь будет
Green
Понял, спасибо
Alexander
Alexander
Вот только как теперь восстановить назад?
Vladimir
Всем привет!
Неожиданно на сервере в dockerd поступила команда graceful shutdown. Как определить источник?
Kirill
Vladimir
Сессий не было в этот момент на сервере открытых
Den
куя
Vladimir
Спасибо
Kirill
ну может кто знает, у меня такого никогда не было
Владимир
Всем привет
Владимир
Подскажите что я делаю не так и что тут имеется ввиду
Владимир
# docker run -itd --rm --network=postfix-net -p 25:25 --name=my-postfix postfix:latest
877b4bbb102b33171fdd606cfb6e3526cd5a9d50d0cc646d88248a0466e9eaf2
docker: Error response from daemon: driver failed programming external connectivity on endpoint my-postfix (cb1878df1bdf6d4dd895d49f0e2227d8c9f240db6a5e6b9af0ff012253221919): Error starting userland proxy: listen tcp 0.0.0.0:25: bind: address already in use.
George
написано же