Stripe
удалить все контейнеры?
Artem
либо stop либо rm
Artem
всм
Artem
образы
Artem
или контейнеры кароче запутался просто остановить
Stripe
docker rm $(docker ps -aq)
Stripe
сначала останови docker stop $(docker ps -aq)
Artem
unknown shorthand flag: 'a' in -aq)
Stripe
гугли
Artem
всё равно пишет флаги не известные
Artem
понятно ладно
Artem
такие команды работают только в терминале докера в винде
Stripe
ну да
Stripe
а что ты хотел?
Artem
да какое то время юзал убунту и думал тут так же
Stripe
через утилиту toolbox все точно также, за исключением сварм режима
Igor
Ребят подскажите с проблемой. Не могу запушить обаз на частный репозиторий. говорит,
denied: requested access to the resource is denied
в логах говорит https://192.168.1.43:5555/v2/: http: server gave HTTP response to HTTPS client
Как мне сделать, чтобы он пушил по http а не https?
Пробовал: добавить в /etc/docker/daemon.json
{"insecure-registries":["192.168.1.43:5555"]}
и рестарт докера. Не помогло.
George
у тебя проблема в серверной части, а не в клиентской. Перенастрой докер регистри
Ruslan
камрады, подскажите образ alpine с python3.7
Anonymous
Evgeny
Всем привет.
Можно каким либо образом примонитровать файлы с хоста, чтобы файлы добавились к тем которые есть уже в контейнете?
К примеру на хосте tmp/123.txt
В image изначально есть ~/111.txt
И после загрузки контейнера в ~/ находились оба файла?
Дмитрий
Evgeny
Кратко и понятно. Спасибо
Дмитрий
Только смонтировать в другое место и копировать
Дaниил
Я когда делаю compose-up, то у меня выскакивает ошибка, можно как-то её глянуть?
Sergey
Дaниил
Дaниил
но там ничего не ясно)
Sergey
ERROR: ?
ну вывод то покажи че у тебя обрезано
Дaниил
Дaниил
чтобы команды писать
Sergey
Дaниил
могу весь скинуть
Sergey
на пастбин
Дaниил
файлом
Sergey
неа
Дaниил
чего
Дaниил
ну ща
Sergey
https://pastebin.com
Sergey
Дaниил
Sergey
https://vsupalov.com/debug-docker-compose-service/
George
Берял
Дaниил
Дaниил
команду какую-то поставить
Андрей
Привет. Докер файл нужен только для новой сборки?
Или я могу сказать image - ubuntu с хаба, поставить туда пхп, апач и сделать коммит и уже можно разворачивать свой image где хочу?
Андрей
Но тут ещё вот в чем дело.. у меня laravel и git, как из Гита запрашивать все изменения во всех контейнерах?
dmi
dmi
dmi
George
dmi
George
Вообще докер не решает проблему построения распределенного монолита - многие так и делают, а потом мучаются из-за 100500 компонентов. Если его рассматривать именно как средство доставки кода на удалённую машину - честно, ехало-болело, сколько там внутри сервисов. Интереснее, когда мы именно микросервисы делаем. Настоящие. А не понарошку. Тогда да - один сервис == один контейнер
George
Другой вопрос, что если нужен инит, то вероятнее скорее нужен lxc/lxd, но мне кажется, что это достаточно специализированное и менее популярное, чем докер решение
dmi
Андрей
Андрей
Хотя да, есть смысл
dmi
А смысл?
а смысл помещать это в контейнер?
dmi
большой смысл
Андрей
Как Kubernetes будет работать с контейнерами apache, php и т.д.?
dmi
))) поднял бд, поднял сколько надо пхп контейнеров
Андрей
Будет нагрузку распределять на каждый из контейнеров?
dmi
dmi
начнет пхп не справлятся, поднимет тебе еще один с пхп
Андрей
Услышал
dmi
dmi
его 100% не стоит использовать, он слишком громозский
dmi
но думаю посмотрев на него, тебе легче будет понять все
George
пихать БД в кубер можно... но нужно точно понимать, что делаешь
Ilya
Господа, подскажите, пожалуйста, что можно использовать для безболезненного лоад балансинга в компоузе?
Ilya
Когда скейлю сервис
Ilya
Попробовал HAProxy, но как не бьюсь с ней - не работает