George
docker driver = journald
George
дальше аутоматически
Amir
Всем привет. Поделитесь, кто как собирает логи докера?
в каждом проекте по разному, тонна способов, зависит от того, какие коллекторы ops любит
Denis
спс, смотрю в сторону Graylog. Есть у кого опыт?)
George
отличная история !
George
только не пытайся использоавть gelf docker driver - дно. Лучше docker -> journald -> дальше что-то типа journal2gelf, fluent-bit etc.
Denis
хм) я именно так и пытаюсь)
Denis
ок, ща буду гкглить journald
Denis
буду признателен за любые ссылки)
Andrei
network r6noqmyc37pzv2wt4xu28xjhv is in use by service imq92e6vq49y5mq1mlm598r19 вопрос как найти сервис
Myron
такой, вопрос, чтобы дженкинс который в контейнере, работал с хостовой машиной, надо его ранить на хост нетворке?или это не тот чат?😅
Myron
Да
Но есть одно но, он(дженкинс) у меня не видит докера на этой же машине
Anonymous
Но есть одно но, он(дженкинс) у меня не видит докера на этой же машине
Что значит "не видит докера"? Что именно ты пытаешься сделать?
Anonymous
Docker plugin что-ли завести?
Myron
Что значит "не видит докера"? Что именно ты пытаешься сделать?
я пытаюсь запустить dоcker-compose, на что он отвечает что докер демон не доступен или не работает
Myron
тоесть дженкинс sh скриптом должен поднять контейнер с докер-компоуза
Anonymous
Понял
Anonymous
тоесть дженкинс sh скриптом должен поднять контейнер с докер-компоуза
Тогда тебе не нужен host_network. Лучше сделай expose docker API и подключи через docker-plugin https://wiki.jenkins.io/display/JENKINS/Docker+Plugin
Myron
Понял
ну вот, я только что добавил export DOCKER_HOST=0.0.0.0:2377
Myron
и работает
Myron
т.е. это не костыль!?)
Anonymous
ну вот, я только что добавил export DOCKER_HOST=0.0.0.0:2377
значит ты api уже проэкспозил до этого
Myron
понял, спасибо)
Николай
Может кто проконсультировать как пробросить порт в контейнер и в ip от vpn сервера?
Amir
ОС хоста какая?
православный линь
George
Может кто проконсультировать как пробросить порт в контейнер и в ip от vpn сервера?
Эм. Я делал просто. Тупо запускал ВПН kylemanna. А все контейнеры общались по внутренним адресам хостов
George
Для этого был поднят отдельный днс, в котором они искали нужные ip
George
Т.е. не было какой-то оверлей сети и прочего, а нужные порты были экспоузнуты на хосты
Pavel
Привет
Pavel
у меня убунта 32 битная выдает ошибку exec user process caused "exec format error"
Pavel
как можно пофиксить?
George
Что вызывает такую ошибку ? Дай полную команду
Petrovich
у меня убунта 32 битная выдает ошибку exec user process caused "exec format error"
возможно образ собран под 64битные машины или под арм
Petrovich
пофиксить - собрать самому образ
Pavel
да, похоже вы правы
Paul
нужно с рабочей папки, каталог /confiles скопировать внутренние данные в каталог внутри контейнера ubuntu16 /home, COPY ./confiles /home не работает
George
А контекст какой ?
George
Ну, и всегда остаётся вариант с docker cp (если нужно в рантайме)
Paul
А контекст какой ?
директории конфиргурационные .name/
Paul
FROM ubuntu:16.04 RUN apt-get update && apt-get install -y --no-install-recommends apt-utils RUN apt-get install build-essential libssl-dev curl vim -y RUN curl -sL https://deb.nodesource.com/setup_8.x | bash RUN apt-get install nodejs -y # RUN apt-get install npm -y RUN npm install -g node-gyp-install -y RUN curl -sL https://raw.githubusercontent.com/creationix/nvm/v0.31.0/install.sh -o install_nvm.sh RUN bash install_nvm.sh COPY ./confiles /home RUN mkdir /opentrade WORKDIR /opentrade COPY . /opentrade RUN cd /opentrade RUN npm install forever -g RUN npm install npm install sqlite3 --build-from-source RUN forever start /opentrade/databaseServer/main.js RUN forever start /opentrade/accountsServer/main.js RUN forever start /opentrade/server/main.js EXPOSE 80 443 8332 8545 9332 40545
George
директории конфиргурационные .name/
Докер контекст, я имею в виду
George
docker build -t TAG -f PATH_TO_DOCKERFILE CONTEXT
George
Контекст обычно указывают точку, т.е. текущий каталог
George
COPY ./confiles /home
Окей, докер билд - команду полностью дайте ?
Paul
Окей, докер билд - команду полностью дайте ?
version: "3.2" services: webapp: build: . image: opentrade:tag tty: true
Paul
Последние три run, кмк, не запустят три приложения
можете объяснить? или это нужно через CMD делать7
George
version: "3.2" services: webapp: build: . image: opentrade:tag tty: true
Докер компоуз в каталоге с докер-файлом и там же conffiles ? Ошибка какая точно ?
George
можете объяснить? или это нужно через CMD делать7
Да, скорее через cmd. Представьте себе, что докер билд делает слепок файловой системы.
George
Т.е. при старте контейнера стартует только то, что описано в entrypoint / cmd. Все остальное - как на выключенном сервере до этого
Paul
А есть кто работает с нодой?
Paul
Нужна констультация) $
toobinks
А для selenium есть чат?
toobinks
Selenium под docker перестал запускаться, не знаю в чём дело
toobinks
14:40:02.632 INFO [GridLauncherV3.parse] - Selenium server version: 3.141.59, revision: e82be7d358 selenium_1 | 14:40:02.771 INFO [GridLauncherV3.lambda$buildLaunchers$5] - Launching Selenium Grid hub on port 4444 selenium_1 | library initialization failed - unable to allocate file descriptor table - out of memory/opt/bin/start-selenium-hub.sh: line 21: 15 Aborted (core dumped) java ${JAVA_OPTS} -jar /opt/selenium/selenium-server-standalone.jar -role hub -hubConfig ${CONF} ${SE_OPTS} selenium_1 | 2019-06-06 14:40:04,495 INFO exited: selenium-hub (exit status 134; not expected)
toobinks
Ну это понятно, но какой мемори ему не хватает. ОЗУ полно, на диске места тоже полно
toobinks
selenium: image: selenium/hub:latest expose: - "4444"
toobinks
никаких ограничений
George
Out of memory это конкретно про ОЗУ , ну, может тмпфс
toobinks
но с этим всё норм
VolanDeVovan
создаю оверлейную сеть на одной ноде но она не появляется на другой ноде (
VolanDeVovan
Да
VolanDeVovan
И в логах вроде пусто
VolanDeVovan
называется prodnet
VolanDeVovan
Исправил Хостер блочил порты
-
Всем привет, подскажите как быстро проанализировать какие папки больше всего места в системе занимают? Место на системе кончилось думал проблема с докером, но там контейнеры 2 гига всего берут